Aviation Academic Training

ENSURE THAT YOUR SYSTEM IS COMPATIBLE
  • Examinations are compatible with all browsers and the Windows + Mac operating systems.
  • Courseware (CBT) is only compatible with Windows PC or Surface Tablets and Microsoft Internet Explorer version 10 or later installed.. Microsoft Edge is not supported.
  • Access our guest account and ensure that your Windows system is compatible with the CBT courseware by doing one of the demo lessons.before subscribing to this service. Login is displayed on the right, username: guest / password: guest
  • Install Adobe Shockwave Player v12 Full version or see System Requirements

Your cart is currently empty.

Return to shop